最近有些客户希望升级openssh和ssl,发现centos默认的库无法直接升级。于是制作了下面的升级命令,分别大家使用。CentOS下用YUM升级OpenSSH和OpenSSL,一行命令搞定:

wget http://www.ctohome.com/linux-vps-pack/webmin/upgrade-openssh.sh;sh upgrade-openssh.sh;

升级成功后会自动重启ssh服务,效果图如下:

Stopping sshd: [  OK  ]
Starting sshd: [  OK  ]

==========   www.CTOHome.com   ============
==========      SSH Version    ============
OpenSSH_5.5p1, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008

[root@225845 ~]# ssh -V
OpenSSH_5.5p1, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008

如果你发现还是ssh4.x版本,而且提示有错误:

openssh-clients-5.5p1-24.el5.i386 from centalt has depsolving problems
--> Missing Dependency: libedit.so.0 is needed by package openssh-clients-5.5p1-24.el5.i386 (centalt)
Error: Missing Dependency: libedit.so.0 is needed by package openssh-clients-5.5p1-24.el5.i386 (centalt)
You could try using --skip-broken to work around the problem

那么,先需要安装libedit0类库,如下:

centos 5.x 32位用如下命令安装

rpm -Uvh ftp://ftp.pbone.net/mirror/atrpms.net/el5-i386/atrpms/stable/libedit0-3.0-1.20090722cvs.el5.i386.rpm

rpm -Uvh http://wangxingcs.com/libedit0-3.0-1.20090722cvs.el5.i386.rpm

centos 5.x 64位用如下命令安装

rpm -Uvh ftp://ftp.pbone.net/mirror/atrpms.net/el5-x86_64/atrpms/stable/libedit0-3.0-1.20090722cvs.el5.x86_64.rpm

其他系统,请在这里找对应版本:

http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/libedit.so.0

PS:如果安装libedit0类库遇到

ldconfig: /usr/lib/libmysqlclient.so.16 is not a symbolic link

ldconfig: /usr/lib/libmysqlclient_r.so.16 is not a symbolic link

提示两个so文件不是符号链接,这时再用ldconfig -v来查看两个文件链接的目标,分析之后重新链接

ln -sf /usr/local/mysql/lib/mysql/libmysqlclient_r.so.16 /usr/lib/libmysqlclient_r.so.16

 

标签: none

添加新评论